IDEAS

Help shape the future of CurseForge!

Add Minecraft 1.7.4 into Minecraft versions

My sister wants to play a Minecraft map, but it only works on 1.7.4, which Curseforge doesn't have. Therefor, Curseforge needs to add 1.7.4 into the list of available Minecraft versions. And while you're at it, maybe add the other versions that aren't listed?

  • Guest
  • Sep 3 2021
  • Attach files